This manual contains information for the safe and proper use of the Levitonix® Service Software. Included are instructions regarding its use, installation, operation and troubleshooting. Please familiarize yourself with the contents of this manual to ensure the safe and effective use. After reading this manual, please store the manual where the personnel responsible for operating the system can readily refer to it at any time.
Contents:

1 INTRODUCTION ......................................................................................................4

2 SYSTEM REQUIREMENTS .....................................................................................5
   2.1 Operating System...............................................................................................5
   2.2 Hardware (for BPS-x).........................................................................................5
   2.3 Hardware (for LPS-x)..........................................................................................5

3 INSTALL LEVITRONIX® SERVICE SOFTWARE ....................................................6

4 UNINSTALL LEVITRONIX® SERVICE SOFTWARE.................................................9
   4.1 Using the Installation File ...................................................................................9
   4.2 Using “Add/Remove Programs” of Windows ....................................................10

5 INSTALLING USB-DRIVERS FOR LPS SERIES ..................................................11
   5.1 Install of USB driver ..........................................................................................11
   5.1.1 Install USB driver under Windows XP SP1 or higher and Windows Vista / 7 ......11
   5.1.2 Install USB driver under Windows XP without Service Pack (manually) ..........13
   5.2 Speed up USB connection ...............................................................................15

6 LAUNCHING SERVICE SOFTWARE ....................................................................16

7 OVERVIEW OF THE WORKSPACE......................................................................21
   7.1 Menu ................................................................................................................22
   7.2 Direct Access Buttons ......................................................................................23
   7.3 Controller Selection ..........................................................................................23
   7.4 Link to Levitronix Homepage ............................................................................24
   7.5 Status of RS232/USB-Connection .....................................................................24
   7.6 Status of Data-Logging .....................................................................................24

8 TOOLS....................................................................................................................25
   8.1 Connection Wizard ...........................................................................................25
   8.1.1 Preparing Communication ............................................................................25
   8.1.2 RS232 Interface (for BPS systems)...............................................................25
   8.1.3 USB Interface (for LPS systems)...................................................................25
8.1.4 Setting up the connection ......................................................................................25
8.2 Interface Display .....................................................................................................26
8.3 Diagnostics .............................................................................................................27
  8.3.1 System Status .......................................................................................................27
  8.3.2 System Diagnostics .............................................................................................27
  8.3.3 System Shutdown Error List ................................................................................27
  8.3.4 Errors Warnings and Message minimum activation period ...................................28
8.4 System Information ..................................................................................................28
  8.4.1 General ................................................................................................................28
  8.4.1.1 Firmware Naming Convention ...........................................................................29
  8.4.2 Controller and Motor data ....................................................................................30
  8.4.3 Service Software Options ....................................................................................30
8.5 Parameter Display ..................................................................................................30
8.6 Firmware Update ....................................................................................................33
8.7 System Control .......................................................................................................36
8.8 Lock/Unlock Controller .........................................................................................37
8.9 EEPROM Editor .....................................................................................................38
8.10 Log Wizard ............................................................................................................40

9 TROUBLESHOOTING OF PUMP SYSTEM ..................................................................42
  9.1 Introduction ............................................................................................................42
  9.2 System in Error State .............................................................................................42
  9.3 Abnormal System Behavior ...................................................................................43

10 TROUBLESHOOTING OF SERVICE SOFTWARE ..................................................46
  10.1 Missing Download Module ...................................................................................46
  10.2 RS232-Connection failed .......................................................................................46
  10.3 Unstable RS232-Communication ..........................................................................47

11 TECHNICAL SUPPORT .............................................................................................48

12 REVISION HISTORY .................................................................................................49
1 Introduction

Levitronix® provides a PC-based Service Software for an easy work with the Levitronix® Bearingless Pump Systems BPS. This Software has the following features:

- Simple integration of a Levitronix® Pump System into an existing application
- Simple firmware update on Levitronix® Controller
- Customization of pump system
- Easy identification of Levitronix® Pump System
- Trouble shooting of any Levitronix® Pump Systems
- Features to prevent unauthorized changes of pump settings
- Logging of up to 8 systems

The Levitronix® Service Software communicates via a RS232-link to a Levitronix® Controller (LC24/LC48/LC72/LC325) respectively via USB-link to Levitronix® Controller (LPS series). Because of the different features and the different controllers there are many firmware versions for each controller type available. To handle the different controller firmware versions the Service Software uses additional PC-based plug-ins called Download Modules. These modules have to be installed on the PC and deliver the firmware specific data to the Service Software. For each controller firmware version, there is a corresponding download module available and this has to be installed on the PC before the Levitronix® Service Software is started up. This relationship is shown in the following figure.

![Figure 1: Overview of software dependence](image-url)
2 System requirements

2.1 Operating System

- Windows 8
- Windows 7
- Windows Vista
- Windows XP
- NT4 with Service Pack 6 and Internet Explorer Version 4.0 or later
- Windows 2000 and Service Pack 2
- Windows 98

2.2 Hardware (for BPS-x)

- RS232-connection on PC side
- RS232-extension cable (not crossed)
- Resolution on screen 800x700 pixel
- Powered up BPS-1, BPS-3 or BPS-4 system and connected via RS232 cable to the PC

⚠️ CAUTION

Some USB to RS232 converters can cause communication problems!
We recommend using Edgeport/1 of Digi International

2.3 Hardware (for LPS-x)

- USB-connection on PC side
- USB-cable
- Resolution on screen 800x700 pixel
- Powered up LPS-x system and connected via USB cable to the PC
3 Install *Levitronix® Service Software*

The *Levitronix® Service Software* is packed in a file named “Levitronix Service Software Ver107.msi”. Double click on this file and the following windows will be shown.

**CAUTION**

If there is an older *Levitronix® Service Software* version installed on the PC remove it before installing the new one. See chapter *Uninstall Service Software*.

Click on “Next >”

Read the License Agreement carefully and hit the accept box.

Click on “Next >”
Type in the user name and the organization.
Hit the “all users” box and click the “Next >” button

Optional screen displayed under Windows Vista or Windows XP SP1 or higher

Choose whether you want to install USB driver for LPC USB controllers.

USB driver can also be installed manually. See Installing USB-Drivers for LPS series

Press “Install” to unpack and copy the needed files

Windows Vista / 7 Users:
The ‘User Account Control’ window appears. Press “→ Allow”
Press “Finish”

If “Install USB driver” was chosen the USB driver installation window appears. Press Extract

Press ‘Next’

Press ‘Finish’
4 Uninstall Levitonix® Service Software

Before the new Levitonix® Service Software can be installed, the older version must be removed to ensure proper work. There are two possibilities to remove it.

4.1 Using the Installation File

If the install file of the old Levitonix® Service Software is still available double click on it and perform the following steps.

Press “Next>”

Hit the “Remove” box and press “Next>”
4.2 Using “Add/Remove Programs” of Windows

1. Click on “Start” → “Settings” → “Control Panel”
2. Double Click on the “Add/Remove Programs” entry (a list of all installed software is been generated)
3. Find the program “Service Software” and press the “Remove” button
4. Follow the displayed instructions on the screen to uninstall the *Levitronix® Service Software*
5 Installing USB-Driver for LPS series

5.1 Install of USB driver

5.1.1 Install USB driver under Windows XP SP1 or higher and Windows Vista / 7

In case the USB driver hasn’t already been installed during installation of Service Software, it’s possible to install the USB driver by rerunning the Service Software Installer.

Start “Levitronix Service Software Ver107.msi” installer. If the Service Software is already installed the following screen appears.

Click on “Next >”  
Choose “Modify” and press “Next >” button.
Click on “Next >”

Choose “Install USB driver” and press “Next >” button.

Click “Install”
5.1.2 Install USB driver under Windows XP without Service Pack (manually)

After connecting the LPS system via USB-cable to the computer windows recognizes new hardware connected.

If "Install USB driver" was chosen the USB driver installation window appears. Press Extract

Press ‘Next’

Press ‘Finish’
"Windows Found New Hardware Wizard" will launch. The screen below is shown. Select "No, not this time" from the options available and then click "Next" to proceed with the installation.

Select "Install from a list or specific location (Advanced)" as shown below and then click "Next".

Select "Search for the best driver in these locations" and enter the file path in the combo-box e.g. "C:\CDM 2.06.00 WHQL Certified" in the example below) or browse to it by clicking the browse button. Once the file path has been entered in the box, click next to proceed.
After copying the required driver files, Windows will display a message indicating that the installation was successful. Click "Finish" to complete the installation for the port of the device.

The Found New Hardware Wizard will launch automatically to install the COM port emulation drivers. As above, select "No, not this time" From the options and click "Next" to proceed with the installation. Select "Install from a list or specific location (Advanced)" as before and then click "Next".

Select "Search for the best driver in these locations" and enter the file path in the combo-box e.g. \"C:\CDM 2.06.00 WHQL Certified \" in the example) or browse to it by clicking the browse button. Once the file path has been entered in the box, click next to proceed.

Windows will display a message indicating that the installation was successful. Click "Finish" to complete the installation.

5.2 Speed up USB connection

Open the Device Manager (located in "Control Panel\System" then select the "Hardware" tab and click "Device Manager") and, the device appears as a "USB Serial Port" within the "Ports (COM & LPT)" entry.

To speed up the USB-communication choose by right-click on this “USB Serial Port” entry the Properties. Within the tab “Port Settings” choose “Advanced...”. Within the Advanced Settings-Window set the “Latency Timer (msec)” within the “BM Options”-Frame to 1.
6 Launching Service Software

The following list shows how to get started with the Levitronix® Service Software. It is important to work through the list step by step.

1. Connect Levitronix® Pump System
   Use serial RS232 interface cable (not crossed) (for BPS Systems) or USB interface cable (for LPS Systems) to connect your PC with the Levitronix® Controller.

2. Power up Levitronix® Pump System

3. Starting up the Levitronix® Service Software
   Click on “Start” → “Programs” → “Service Software”
   The Service Software workspace starts up. If no connection is found or the Service Software is started up for the first time, the Connection Wizard is shown.

4. Setting up the connection (Connection Wizard)
   The Service Software needs to know which COM port of the PC is connected with the Levitronix® Pump System. Therefore choose the COM port.
To refresh Com port list press ‘F5’ key.

Press the “Add”-button to check out the connection.
If this message appears, the connection is set up successfully.

With the same proceeding you can add up to 8 connections to controllers. For getting the full functionality for every connection, it is highly important to have the same firmware on every connected controller.

If there is not the same firmware on the newly connected controller as on the first controller connected to the Service Software, you will not have full functionality within the Service Software for this connection. An update of the firmware on this controller will be the only possible action.
5. Giving a specific name to the connection

For every connected controller add a specific name, this name will also appear as the name of the corresponding buttons in the 'Controller Section'.

6. Start using *Levitronix® Service Software*

The workspace is open and ready to work with.
7. Removing an existing connection

Similar to the proceeding to set up a connection you can remove an existing connection by choosing the COM Port in the menu and pressing the “Remove” button.

Click on the “OK” button to close this window.
7 Overview of the Workspace

![Image of the Levitonix Service Software Workspace]

- **Menu**
- **Direct access buttons**
- **Link to the Levitonix Homepage**
- **Controller Selection**
- **Status of RS232/USB-Connection**
- **Status of Data Logging**

*Figure 2: Overview of the Levitonix® Service Software Workspace*
### 7.1 Menu

<table>
<thead>
<tr>
<th>1st level</th>
<th>2nd level</th>
<th>3rd level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Options</td>
<td>Temperature Graph</td>
<td>Adjustment of time range for the temperature graph in the Parameter Display Window</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Speed Graph</td>
<td>Adjustment of time range for the speed graph in the Parameter Display Window</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Process Values</td>
<td>Adjustment of time range for the process value graph in the Parameter Display Window</td>
</tr>
<tr>
<td></td>
<td>Units</td>
<td>Setting of the preference units</td>
<td></td>
</tr>
<tr>
<td>Tools</td>
<td>Connection Wizard</td>
<td>Sets up a connection</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interface Display</td>
<td>Shows the analog and digital signals of the User Interface</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Diagnostics</td>
<td>Shows the actual state of the pump system</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System Information</td>
<td>Determine the connected system (type, serial number..)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Parameter Display</td>
<td>Shows actual system values graphically</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Firmware Update</td>
<td>Updates the controller with a new firmware</td>
<td></td>
</tr>
<tr>
<td></td>
<td>System Control</td>
<td>Controls the pump system by PC</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Lock / Unlock Controller</td>
<td>Protects pump system from unauthorized manipulations (such as changes of the actual settings, firmware updates)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>EEPROM Editor</td>
<td>Customizes the pump system for special applications</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Log Wizard</td>
<td>Assists in troubleshooting of pump systems</td>
<td></td>
</tr>
<tr>
<td>Windows</td>
<td>Cascade</td>
<td>Arranges the open windows</td>
<td></td>
</tr>
<tr>
<td>About</td>
<td>Help</td>
<td>Opens help</td>
<td></td>
</tr>
<tr>
<td></td>
<td>About Service Software</td>
<td>Shows the version of the Service Software and the contact to Levitonix®</td>
<td></td>
</tr>
</tbody>
</table>

**Table 1: The Structure of the Menu**
7.2 Direct Access Buttons

Click on the Icon of the toolbar to open or close the corresponding window.

![Figure 3: Overview of the Direct Access Buttons](image)

7.3 Controller Selection

Click the icon of a pump system to gain full control. For every opened connection to a pump system there will appear a new Icon in this section. The red color of the icon shows the actual 'Master System'. For this chosen 'Master System' you have the full control (if you have installed the same firmware as on the system, you have connected as the first)

![Figure 4: Overview of the Controller Selection](image)
7.4 Link to Levitronix Homepage

If your PC is connected to the internet press the Levitronix® picture to open the Levitronix® Homepage and learn more about the company and its technology.

7.5 Status of RS232/USB-Connection

This section shows the status of the RS232/USB-connection.

7.6 Status of Data-Logging

The message “data log active” is shown if the data logging function is started.
8 Tools

8.1 Connection Wizard

8.1.1 Preparing Communication

Please make sure the following components are provided to ensure a problem free connection:

- Power supply unit for LC24, LC48 or LC72 resp. LPC-200, LPC-600
- *Levitronix*® Controller
- Motor
- Power output cable (controller-to-motor)
- Power input cable (PSU-to-controller)
- RS232 cable (non-crossed) (for BPS systems) / USB cable, type A-B (for LPS systems)

8.1.2 RS232 Interface (for BPS systems)

The *Levitronix*® Service Software communicates with the controller via serial link connected to a RS232 interface (COM Port) on the PC. The selected cable is required not to be crossed and must have a male DSUB connector at controller side. The connector on the other end of the cable depends on the RS232 Interface of the PC, but in most cases a female DSUB is used.

8.1.3 USB Interface (for LPS systems)

The *Levitronix*® Service Software communicates with the controller via serial link connected to a USB interface (generated COM Port) on the PC. The selected cable is required to be a standard type USB cable, type A-B. The smaller end of the cable (type B) is connected to the controller, where the flat end (type A) is the one which will be connected to the PC.

8.1.4 Setting up the connection

Press "Tools" → "Connection Wizard" to set up a new connection. Select the COM port you have plugged in the RS232 cable before or test them one-by-one if you are not sure which port the cable is connected with. See chapter 6 "Launching Service Software" for details on initializing service software and chapter 10 "Trouble Shooting of Service Software" if there are difficulties in getting properly connected.
8.2 **Interface Display**

The **PLC Interface Display** shows the actual signal values of the PLC interface, which is opened in the menu “**Tools**” → “**Interface Display**”. Use this tool for configuration and integration of the pump system. The visible signals and the corresponding description and scaling are a function of the installed firmware on the controller. The Interface Display may vary depending on the firmware revision used. The following figure is just an example of one particular firmware:

![PLC Interface Display](image)

*Figure 5: PLC Interface Display in the Levitronix® Service Software*
8.3 Diagnostics

Click on “Tools” → “Diagnostics” to open the Diagnostics Window. This tool shows the actual state of the pump system. There are three different levels of information provided by the Levitonix® Controller. A ‘message’ consists of information which has no effect on the function of the system. If a ‘warning’ is active the pump itself is still running but it is necessary to have a closer look on the system. Whenever an ‘error’ is active, the system shuts down and should be debugged.

The next picture shows an overview of the Diagnostics Window. Dependant of the firmware installed on the controller some sections may be hidden because they’re not supported by the firmware. The ‘Message’ section is hidden by default it can be enabled under “File” → “Options” → “Diagnostic”

![Figure 6: Overview of the Diagnostics Window](image)

8.3.1 System Status

The corresponding lamp lights up if an error, warning or message is active and its

8.3.2 System Diagnostics

The diagnosis is prepared if an error, warning or message is active. The yellow line shows the corrective actions which should be done to prevent the pump system from this state. The history logs all the occurrences since the Diagnostics Window was opened.

8.3.3 System Shutdown Error List

Some controller firmware versions support this function. Whenever an error occurs when the pump system is running (levitating) the error will be stored in the EEPROM of the controller and visible even when the Service Software was not opened. The last four errors are stored in the error list. To delete the list, press the “Clear List” button.
8.3.4 Errors Warnings and Message minimum activation period

Newer LPC controller firmware versions support this function. Some errors, warnings or messages are only active for a very short time. If this time is less than a Service Software sampling period it won’t be shown or logged.

The display of an error/warning/message can be extended by a defined minimum activation period. Note this minimum activation period has no effect on the behavior of the pump itself, it prolongs only the visibility in the diagnostic window and data log file.

If the pump firmware supports this minimum activation period feature, it can be enabled under “File” → “Options” → “Diagnostic”.

8.4 System Information

The system information tool examines the connected components and lists the information like the example below.

![System Information](image)

**Figure 7: PLC Interface Display in the Levitronix® Service Software**

8.4.1 General

In the General section, the actual installed firmware on the Levitronix® Controller is shown and the system type (BPS-1, BPS-3 or BPS-4 or D600, …). See user manual of the corresponding BPS System for detailed information.
8.4.1.1 Firmware Naming Convention

The naming convention of a firmware version for a controller is shown below. Sometimes it may be helpful to know the difference between any firmware versions. The name of the firmware includes useful information. The following figure shows the structure of a firmware name.

The system identification portion of the name conveys which BPS system this firmware is associated with. Currently, there are numerous firmware versions available for special applications and hardware sets. The hardware and feature portion of the number conveys which set of features are included in the firmware. For detailed information about the features, see the firmware specification sheet. The last part of the name shows the revision. The revision increases if a bug fix was completed or additional features are included. The additional features are disabled by default and can be enabled by using the EEPROM-Editor tool. The revisions are always downwards compatible. The next figure shows a summary of this.

<table>
<thead>
<tr>
<th>System identification</th>
<th>Hardware &amp; Features</th>
<th>Revision</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Letter</strong></td>
<td><strong>System</strong></td>
<td><strong>Number</strong></td>
</tr>
<tr>
<td>P</td>
<td>BPS-1</td>
<td>2.37</td>
</tr>
<tr>
<td>R</td>
<td>BPS-3</td>
<td></td>
</tr>
<tr>
<td>S</td>
<td>BPS-4</td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>BPS-200</td>
<td></td>
</tr>
<tr>
<td>D</td>
<td>BPS-600</td>
<td></td>
</tr>
<tr>
<td>E</td>
<td>BPS-2000</td>
<td></td>
</tr>
<tr>
<td>F</td>
<td>BPS-4000</td>
<td></td>
</tr>
</tbody>
</table>

Figure 8: Firmware name structure

Figure 9: Firmware name summary
8.4.2 Controller and Motor data

Levitronix\textsuperscript{\textregistered} controllers and motors receive a serial number when each is shipped to a customer. This serial number is visible on a sticker attached on the surface of these parts and it is stored in the EEPROM of the controller and of the motor itself. This process allows for component tracking in the field when required.

8.4.3 Service Software Options

The Service Software offers the possibility to edit some EEPROM-values (see chapter 8.9 EEPROM-Editor). A standard Download Module offers a certain set of often used values to change. This set is called default and it is shown at the position EEPROM Editor Mask. For special needs it is possible to change this set of values and the name of the new set will be displayed.

By default the Service Software has a set of functions used. The name of this standard set is shown at the Specification File (default). For some special needs it is possible to generate a new set of functions and additionally, its name will be displayed too.

8.5 Parameter Display

The Parameter Display shows the chronological course of some important key values of the pump system. By default, there are four different graphical displays available. The first one shows the temperature of the Levitronix\textsuperscript{\textregistered} controller and of the motor. The second one shows the actual speed and the set point speed of the rotor inside the pump head. The third graph is used for the set point process value and the actual process value (in most cases this is used for closed loop flow control or closed loop pressure control). The fourth graph can display a value of the system chosen by the user. The value which the user would like to monitor can be chosen by the drop-down menu. All of the graphs have a time base which can be changed (see chapter menu for time line adjustment).

The last window shows a table with additional important values of the system. The values shown in this list are the same the user can choose in the parameter graph to monitor over time. If the logging function of the Service Software is used, these values will be logged in a file (see chapter data log). This parameter list is distinguished between the different Download Modules.

Figure 10: Temperature graph (green: controller temperature; red: motor temperature)
Figure 11: Speed graph (green: set point; red: actual speed)

Figure 12: Process values (green: set point; red actual process value)
Figure 13: Parameter Graph (example)

Figure 14: Parameter List (example)
8.6 Firmware Update

*Levitronix®* delivers the pump systems with a standard firmware burned into memory. In some cases, customers need to update the currently loaded firmware because of a special application or if some new features are required. The *Levitronix® Service Software* offers the possibility to update the controller with a new firmware. To use this feature, it is necessary to install the appropriate *Download Module* which includes the executable code for the *Levitronix® Controller*.

⚠ **CAUTION**

Do not disconnect the RS232/USB cable or power off the pump system during the update procedure! The system may become damaged.

1. Click on **Tools → Firmware Update** to open the firmware update dialog box. *Levitronix® Service Software* detects the system type of the connected pump system. Please double check this information and press **Ok** to confirm or press **Select** to choose your system manually.

2. A list of all installed download modules (with the corresponding executable code of the *Levitronix® Controller*) for the selected system type is shown. Please select a firmware version to install on the controller and confirm with **Ok**.

If the connected pump system is controlled by a PLC, the PLC interface looses its priority and the *Service Software* stops the pump (controlled shut down and rotor in home position)!

4. Click Yes to stop the pump and start the firmware update procedure.

   Do not disconnect the RS232/USB cable or switch off the power during this procedure!

5. Please stand by during the update procedure.
6. If the firmware update is finished a message with the new firmware version is shown.

Press Ok.
8.7 System Control

Open the System Control Dialog Box in the menu “Tools” → “System Control”, which is used for turning the system on/off and switching between speed and process (flow/pressure) mode. Set the set point value with the appropriate buttons.

Change the operation mode of the system by pressing

- Enter Process Mode button or
- Enter Speed Mode button.

ATTENTION: The System Control box is disabled when the system is operated via PLC!

Figure 15: System Operation of the Bearingless Pump System in the Levitronix® Service Software (left: Speed Mode, right: Process Mode)
8.8 Lock/Unlock Controller

The lock / unlock tool allows protection of the Levitonix® Controller from unauthorized firmware updates and EEPROM manipulations. The controller can be protected with a password of 4-8 characters. After locking the controller it is necessary to type in the password for performing the firmware update or using the EEPROM Editor. To unlock the controller open the Lock / Unlock tool again and type in the password.

⚠ CAUTION

Write down the password together with the serial number of the locked controller.
8.9 EEPROM Editor

The pump system can be configured in the **EEPROM Editor**, which is opened in the menu “Tools” → “EEPROM Editor”. It is divided into three sections. The upper portion consists of the EEPROM values. These values are dependent on the firmware installed on the controller.

The different sheets can be selected by the tabs in the *Tab* section.

The buttons in the global parameter change section have an effect on all parameter sheets. The visible parameters on the current sheet and parameters on the hidden sheets are influenced by pressing any of these buttons.

After setting the values in the **EEPROM Editor** they are downloaded to the pump controller whenever clicking the *Write to RAM* button. As long as they are not written to RAM the values in the EEPROM Editor and those in the RAM do not correspond. This is signalized by their red color. After writing to RAM the values are stored only in RAM on the pump controller and thus are lost after a reset or the loss of power. To prevent the loss of these values, please ensure the *Write to EEPROM button is pressed*. Check the actual parameter values in the pump controller by clicking the *Read from RAM* button. While launching the EEPROM Editor the actual RAM values will be uploaded and displayed.

The basic function of the **EEPROM Editor** is shown in Figure 17.
Table of contents

Figure 17: Basic function of the EEPROM Editor in the Levitronix® Service Software

ATTENTION: Ensure that the correct values are set in the Service Software before pressing any Write button!

ATTENTION: Press the Write to RAM or Write to EEPROM button (in the Global Parameter Changes section) after importing the parameters from a file to download the parameters to the controller!

Figure 18: Global Parameter Changes in the EEPROM Editor of the Levitronix® Service Software

Press the Clear EEPROM button to set back the default setting. After a system reset or a power down the factory default values will taking effect.

EEPROM parameter sets can be imported and exported from/to storable files as well. Use the Import and Export buttons. Keep in mind that the exported values only can be imported if the same firmware is installed on the controller. If a file was imported the values are shown in the EEPROM editor mask. Use the write buttons to transfer the values to the controller.
8.10 Log Wizard

The *Levitronix® Service Software* is able to log up to eight systems at the same time. Within the Log wizard you can enable or disable the logging of the individual systems. By pressing the 'Start'-Button all the enabled data loggings are initiated. Changing of Log-File name and directory is possible. While data logging is active consecutive files with the configured file length are generated. To distinguish the consecutive files there is a file counter running for every connected system. Every time a new file has been generated (which happens whenever the specified file length is reached) this counter is incremented. The value of the counter is appended at the end of every Log-File name. By changing the Log-File name you reset its corresponding counter to 0. The setting of the sample interval and the file-length of the logging files can also be configured in the Log Wizard. The sample interval indicates the time between two successive data entries. To be sure that the sample interval can be fulfilled, it is recommended to close all additional windows within *Levitronix® Service Software*. ‘Filelength’ means the length in MB after which the *Levitronix® Service Software* creates a new file with a consecutive number. Directory, Interval Time and File Length will be the same for every added COM-Port.

To generate the momentarily running Log-File(s) in the chosen folder you will have to disable the logging by pressing the ‘Stop’-Button. The generation of the Log-Files is also initiated when closing *Levitronix® Service Software*, updating the firmware of a controller and removing or losing a connection to a controller during data-log.

By clicking ‘Enable Logging at Startup’ you have the possibility to start logging automatically after launching the *Levitronix® Service Software* with all the settings of the previous session. The data logging will be started in a new file with increased file number as postfix at the end of the filename.

⚠️ **CAUTION**

If you entered a new name and afterwards you change the name back to an already existing filename, all the old data with the same filename will be overwritten, because numbering restarts from 0.
Figure 19: Log Wizard in the Levitonix® Service Software
9 Troubleshooting of Pump System

9.1 Introduction

This section describes a very, short and precise an action list, whenever an issue of a *Levitronix® Bearingless Pump System* arises. It is basically distinguished between two situations:

a) The *Bearingless Pump System* is not running and an error and/or warning flag is active, the system is in the so-called *Error State* ⇒ see Chapter 9.2.

b) The *Bearingless Pump System* is basically running, but abnormal system behavior is observed ⇒ see Chapter 9.3.

*Use the Levitronix Service Software for performing troubleshooting.*

9.2 System in Error State

The purpose of the described procedure is to obtain information about the actual pending error/warning by using the *System Diagnostics Window* of the *Levitronix®* Service Software.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Double-click the Service Software icon or click the Service Software entry in the program list.</td>
</tr>
</tbody>
</table>
| 2. | Use the Connection Wizard (Menu Tools → Connection Wizard) to establish communication.  
  a) Choose the COM port.  
  b) Establish the communication with the *Levitronix®* controller by pressing the Add Button. |
3. a) Open the Diagnostics window (Menu Tools → Diagnostics).
   b) Take a screenshot of the Window or note the Error/Warning Message + its hexadecimal code (e.g. 0x100h).

4. E-mail the information to Levitronix®.

9.3 Abnormal System Behavior

The purpose of the described procedure is to obtain information about the actual system condition by using the Data Log feature of the Levitronix® Service Software, which is logging system internal parameters like pump speed, bearing and drive currents, axial position, etc.

ATTENTION: Please ensure that the “abnormal system behavior” of the pump system is occurring during the data logging process described below!

1. Double-click the Service Software icon or click the Service Software entry in the program list.

2. Use the Connection Wizard (Menu “Tools” → “Connection Wizard”) to establish communication.
   a) Choose the COM port.
   b) Establish the communication with the Levitronix® controller by pressing the Add button.
3. Log system parameters with data logging feature.
   a) Open the Log Wizard (Menu “Tools” → “Log Wizard”).
   b) Set the sample Interval to 1 sec.
   c) Enter a filename.
   d) Select a file path.
   e) Enable the Data Log.
   f) Press the Start button.
   g) Close the Data Log window.

4. Double-check, if the data logger is running in the lower right corner of the Service Software and wait for at least 5 min (Ensure occurrence of abnormal system behavior during data logging!).

5. Stop data logging feature.
   a) Open the Log Wizard (Menu “Tools” → “Log Wizard”).
   b) Press the Stop button.
   c) Disable the Data Log.
   d) Close the Data Log window.

6. The data log file has now be generated in the chosen folder.
<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>7.</td>
<td>Double-check, if the data logger is disabled in the lower right corner of the Service Software.</td>
</tr>
<tr>
<td>8.</td>
<td>E-mail the data log file to Levitonix®.</td>
</tr>
</tbody>
</table>
10 Troubleshooting of Service Software

10.1 Missing Download Module

Figure 20: Example of a Missing Download Module Message

If the Download Module Missing dialog box is shown the Levitonix® Service Software needs a special plug-in to communicate and to handle the connected pump system. Ask your local supplier or contact Levitonix® to get this installation file for your PC.

10.2 RS232-Connection failed

Symptom:
It is not possible to open a RS232 connection.

Causes and solutions:

1.) Is the RS232-cable connected correctly?
2.) Is the controller supplied with power?
3.) Do you have selected the right COM-port? Check out different COM-ports
4.) Try another RS232 cable (not crossed!)
5.) Is the selected COM-port used by other applications such as PALM, Pocket PC’s, Cellular phones? De-install these devices or choose another COM-port (It is important to de-install the driver for these devices too)
6.) If no RS232-port is available then install a PCI-card with additional RS232-ports for desktop PCs or a PCMCIA RS232 card for Laptops (do not use any USB-RS232 interfaces)
10.3 Unstable RS232-Communication

**Symptom:**

The RS232 connection is established but some windows have communication faults. The communication seems to be unstable.

**Causes and solutions:**

1.) Do not use USB to RS232 interfaces. These devices do not provide the complete functionality of a standard RS232 port even if the supplier states otherwise. Instead, use PCI or PCMCIA cards to generate additional RS232 ports.

2.) Decrease the buffer length of the used RS232 port. Open “Start” → “Control Panel” → “Administrative Tools” → “Computer Management” → “Device Manager” → “Ports” and select the used COM-port. Watch out for Receive and Transmit Buffer settings and set them as high as possible (this setting is hardware dependant; some serial cards have this possibility).
11 Technical Support

For further troubleshooting assistance, support and detailed technical information contact \textit{Levitronix\textsuperscript{\textregistered} Technical Service Department}:

\begin{center}
\textit{Levitronix Technical Service Department}  
Technoparkstrasse 1  
8005 Zurich  
Switzerland  

Phone for US: 888-569-0718  
Phone for Outside US: +1-888-569-0718  
E-Mail: support@levitronix.com
\end{center}
# 12 Revision History

<table>
<thead>
<tr>
<th>Doc. Rev.</th>
<th>Belongs to</th>
<th>DCO No.</th>
<th>DCO Author</th>
<th>Effectivity Date</th>
<th>Summary Description of Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>00</td>
<td>LSS Ver94</td>
<td>05-031</td>
<td>Stoeckli</td>
<td>15-04-05</td>
<td>First Release</td>
</tr>
<tr>
<td>01</td>
<td>LSS Ver95</td>
<td>05-082</td>
<td>Zingg</td>
<td>29-09-05</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New Splashscreen</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New Exe-Icon</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Help-Icon removed</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Hotlinenumber included in About-Window</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Opening EEPROM-Editor initiates reading from RAM to get the actual values which are on the controller instead of using Defaultvalues</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Clicking ‘Write to RAM‘- Button will do automatically a ‘Read from RAM‘ after writing to get the actual values</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- RAM/EEPROM-Interaktion just Global possible (for all values)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Mousepointer gets hourglass in time-consuming actions</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- if connection lost, windows just get deactivated not closed</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Shortcut on the desktop; will be removed when LSS gets deinstalled</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td>02</td>
<td>LSS Ver96</td>
<td>06-001</td>
<td>Zingg</td>
<td>05-01-06</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td>Beta</td>
<td></td>
<td></td>
<td></td>
<td>- Master/Slavesystems concept with ability to monitor and handle upto 8 systems</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Adding and removing of connections with Connection Wizard</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Every System is represented with a button, red button: master system</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Name for every system can be set</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New CTS: no virtual memory problems anymore</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Connect/Disconnect button removed</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Logging Wizard with ability to log upto 8 systems at the same time</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Fielength in days configurable</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Logfile will be generated on deactivation of logging</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Parameter display remains active after system reset</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Only systems with same firmware as the first one connected will have full service software functionality</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- USB-RS232 Converters Connection Lost problem solved</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td>03</td>
<td>LSS Ver96</td>
<td>06-042</td>
<td>Zingg</td>
<td>22-03-06</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Same Functionality as Ver 96_beta, only difference is Log Wizard</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Enable-logging-at-start-up functionality to put LSS in Windows startup</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Logging in various, consecutive log-files with upto 30 MB length</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New blackbox.dat file included to get new warnings and messages: Dryrunning and XY-Observation</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver96 Beta</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver96 Beta</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver96</td>
</tr>
</tbody>
</table>

---

[Back to top](#)
<table>
<thead>
<tr>
<th>Doc. Rev.</th>
<th>Belongs to</th>
<th>DCO No.</th>
<th>DCO Author</th>
<th>Effectivity Date</th>
<th>Summary Description of Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>04</td>
<td>LSS Ver97</td>
<td></td>
<td>Zingg</td>
<td>21-12-06</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New CTS, which is able to handle the two types of systems (BPS, LPS)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New blackbox.dat file to recognize new warnings and messages of LPS system</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- When starting up Service Software tries to connect first to a BPS system, when this fails tries to launch a connection to a LPS system</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Parameter Graph within Parameter Display where a variable from the Parameter List can be chosen via drop-down menu to monitor over time.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver97</td>
</tr>
<tr>
<td>05</td>
<td>LSS Ver98</td>
<td>07-160</td>
<td>Kalapos</td>
<td>26-10-07</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Resets LPS systems after bootload</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New diagnostics window (controller ‘Messages’ hidden by default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Support of new LPS systems</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Bugfix: Logging didn’t work on non-english windows xp installation (C:\Programme instead C:\Program Files)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Logging: Error, Warning and Messages are stored in hexadecimal + description string</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Windows Vista compatibility</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Windows 98: Fixed splash screen bug</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Added new CDM USB driver</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver98</td>
</tr>
<tr>
<td>06</td>
<td>LSS Ver99</td>
<td>07-173</td>
<td>Kalapos</td>
<td>9-11-07</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Added missing error, warning and message descriptions (diagnostic window)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver99</td>
</tr>
<tr>
<td>07</td>
<td>LSS Ver100</td>
<td>08-001</td>
<td>Kalapos</td>
<td>4-01-08</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Added missing ‘error’, ‘warning’ and ‘message’ descriptions (diagnostic window)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Bugfix: Diagnostic window. PIT_Errors frame wasn’t visible.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Supports ‘firmware update’ of new systems (LPS)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver100</td>
</tr>
<tr>
<td>Doc. Rev.</td>
<td>Belongs to</td>
<td>DCO No.</td>
<td>DCO Author</td>
<td>Effectivity Date</td>
<td>Summary Description of Changes</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>---------</td>
<td>------------</td>
<td>------------------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td>08</td>
<td>LSS Ver101</td>
<td>09-132</td>
<td>Kalapos</td>
<td>13-08-09</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Bugfix: Couldn’t update / open eeprom editor if a LPC controller with an negative AD-converter offset (AIN_Offset) was connected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Bugfix: Diagnostic window. System Power off generated an errormessage ‘Run-time error 35600: Index out of bounds’</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Bugfix: System control window. Maximum value in process mode became 0.03 % if SS was used with a flowcalculator firmware before.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New cts.exe: Bugfix: If USB cable was removed while communicating, the cts.exe generated a lot of error popup messages.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Parameter window: Increased default speed maximum to 10000 rpm</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Fix: Reconnect LPC systems automatically after bootloader</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Connection window: Marks connected USB LPC controllers with a ‘(USB)’. Sets USB latency timer to 1 ms if possible (Needs sufficient permission rights)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver101</td>
</tr>
<tr>
<td>09</td>
<td>LSS Ver102</td>
<td>10-048</td>
<td>Kalapos</td>
<td>01-03-10</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Connection window: Added option: Displays only physically available serial ports. Can open serial ports up to COM256.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Interface display window: Can display 4th digital input / output</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- New cts.exe: Bugfix: Improved communication to LPC controllers through connectport ts mei server.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Added new USB driver to installer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Bugfix: Couldn’t lock LPC-Controllers.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Windows Vista: Bugfix: Default logfile name wasn’t properly set to ‘Datalog_COMx’</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Tested LSS with Windows 7</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Changes according to LSS Ver102</td>
</tr>
<tr>
<td>10</td>
<td>LSS Ver103</td>
<td>10-126</td>
<td>Kalapos</td>
<td>08-06-10</td>
<td>Changes in LSS</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- System Control: Speed/Flow setpoint wasn’t set if pump was stopped and restarted immediately (Turn levitation ON)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Bugfix: Export of EEPROM values didn’t work if there were checkbox properties.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- Parameter display: Parameter list: Errors, warnings and messages values are displayed as hexadecimal number.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Changes in Manual</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- No changes.</td>
</tr>
<tr>
<td>Doc. Rev.</td>
<td>Belongs to</td>
<td>DCO No.</td>
<td>DCO Author</td>
<td>Effectivity Date</td>
<td>Summary Description of Changes</td>
</tr>
<tr>
<td>----------</td>
<td>------------</td>
<td>---------</td>
<td>------------</td>
<td>------------------</td>
<td>--------------------------------</td>
</tr>
</tbody>
</table>
| 11       | LSS Ver104 | 11-194  | Kalapos    | 7-11-11          | **Changes in LSS**  
- Parameter Display:  
  Double click on process value graph causes a zoom in to actual process value ± 5%  
- Bugfix: Parameter Graph displayed Parameter List if firmware supported only 4 tabs  
- Bugfix: If user connected to a second pump with different firmware, PLC window, parameter graph window and system control window were changed and didn't work properly. Same situation could cause issues during data logging.  
- Removed old help file and added User Manual for Levitronix Service Software to installer. Service Software opens user manual at the right page if user presses 'F1' key. Requires installed acrobat reader.  
- Added new diagnostic ‘message code’ descriptions.  
- Added version string to data log file and title bar.  
- Support for ‘minimum activation period’ for diagnostic errors, warnings and messages  
- Added newest USB driver 2.08.14 to installer.  
- Optimized GUI for smaller screens  
**Changes in Manual**  
- Added chapter 8.3.4  
- Revised chapter 8.10  
- Updated figure numbering  
- Updated diagnostic screenshot |
| 12       | LSS Ver105 | 12-010  | Kalapos    | 10-12-12         | **Changes in LSS**  
- Bugfix: Communication timing issues with LC325(P), LC46 and LC24 controllers. Could cause Message ‘The Device did not respond within given time’ or signal drops in the Parameter Display graphs and PLC interface display. These issues occur more frequent on Windows 7 systems.  
- Diagnostic Window: Messages are activated immediately. User doesn’t need to reopen window if option was changed.  
- Parameter Display: Speed tab. Higher speed resolution if maximum is < 1500.  
- Bugfix: Popup flood if diagnostic window was open while connection was lost.  
- Added newest USB driver 2.08.24 to installer.  
**Changes in Manual**  
- None |
| 13       | LSS Ver106 | 13-037  | Kalapos    | 05-06-13         | **Changes in LSS**  
- Added support for integrated pump systems:  
  Software reset button appears as direct access button  
- Parameter Display: Set maximum speed in graph to maximum speed of pump + 1000 rpm  
- Bugfix: LSS could crash with ‘Runtime error ’13’. If LSS was connected to more than 2 pump systems and EEPROM editor or Diagnostic Window or Lock/Unlock Controller window is opened.  
- Firmware Update Window: Password check was moved to the beginning of firmware update procedure.  
- Added newest USB driver 2.08.28 to installer.  
**Changes in Manual**  
- None |
<table>
<thead>
<tr>
<th>Doc. Rev.</th>
<th>Belongs to DCO No.</th>
<th>DCO Author</th>
<th>Effectivity Date</th>
<th>Summary Description of Changes</th>
</tr>
</thead>
</table>
| 14       | LSS Ver107 13-061 Kalapos 19-07-13 | Changes in LSS  
- Bugfix: LSS could crash with ‘Runtime error ‘13’. If user connects to a pump after at least 2 unsuccessful connection attempts and opens either EEPROM editor or Diagnostic Window or Lock/Unlock Controller or Firmware update window.  
- Added manifest file to force windows to execute LSS in administrator mode. If LSS is executed without sufficient rights CTS.exe generates error popups ‘The requested lookup key was not found in any active activation context,’ and ‘Could not load communication modules’ and ‘*.plg’.  
- Bugfix: LSS could crash in Firmware Update Window while displaying installed download modules list.  
- Revised Firmware update window procedure: No user interaction needed between pump system stop and firmware update.  

Changes in Manual  
- Chapter 8.6: New firmware update procedure. |